RFR: Renaming cleanup on slow path [v3]

Coleen Phillimore coleenp at openjdk.java.net
Tue Apr 26 21:57:43 UTC 2022


On Tue, 26 Apr 2022 18:09:30 GMT, Patricio Chilano Mateo <pchilanomate at openjdk.org> wrote:

>> Some renaming on the slow path. Testing loom-tiers1-3.
>
> Patricio Chilano Mateo has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains seven commits:
> 
>  - merge
>  - Fred review
>  - rename freeze/recurse_freeze & thaw_one_frame/recurse_thaw
>  - add frame_bottom variable
>  - rename heap_sp to heap_top
>  - rename frame_sp to frame_top
>  - rename bottom to is_bottom_frame

Still good.

src/hotspot/share/runtime/continuationFreezeThaw.cpp line 2011:

> 2009: 
> 2010:   assert(hf.is_heap_frame(), "should be");
> 2011:   const int fsize = heap_frame_bottom - heap_frame_top;

I think fsize could use a better name too.  Maybe next go-around?

-------------

Marked as reviewed by coleenp (Committer).

PR: https://git.openjdk.java.net/loom/pull/170


More information about the loom-dev mailing list