8165103: Update to "denyAfter constraint check" exception message
valerie.peng at oracle.com
Fri Oct 7 00:06:09 UTC 2016
I know it's intentional, however I doubt how much difference this makes.
Code duplication is kind of error prone.
Just my preference,
On 10/5/2016 8:29 PM, Anthony Scarpino wrote:
> This is intentional as an optimization. Setting the String is only
> needed in the failure case, so I separated them to optimize the
> success case. That's why I have the comment there.
> On 10/05/2016 04:58 PM, Valerie Peng wrote:
>> Instead of duplicating the if-check block, how about just add another
>> String variable "dateType" and assign value to it in the first if-check
>> Rest looks fine.
>> On 10/5/2016 1:20 PM, Anthony Scarpino wrote:
>>> I'd like a review of this change away from a generic error messages in
>>> the denyAfter constraint. The message better specify which date was
>>> checked against the constraint now. Testing is handled elsewhere.
More information about the security-dev