RFR: git-pr: rename "update" to "set"
rwestberg at openjdk.java.net
Tue Feb 18 13:01:24 UTC 2020
On Tue, 18 Feb 2020 12:43:14 GMT, Erik Helin <ehelin at openjdk.org> wrote:
> Hi all,
> please review this patch that renames the `git pr` subcommand `update` to `set`.
> This is done for a couple of reasons:
> - `update` can be viewed as appending or enhancing whereas `set` better reflects
> that we do set some fields (i.e. all existing values for the field has to be
> repeated for appending).
> - `update` is freed up to be user for future commands
> - `set` is shorter than `update`
> Examples of how the command is intended to be used are `git pr set
> --assignees=rwestberg`, `git pr set --reviewers=JornVernee` and `git pr set
> - Manual testing of `git pr set`
Marked as reviewed by rwestberg (Reviewer).
More information about the skara-dev