FYI: Update the isReady condition for the notifier

Erik Helin ehelin at openjdk.java.net
Fri Jun 12 13:49:17 UTC 2020


On Fri, 12 Jun 2020 13:34:13 GMT, Robin Westberg <rwestberg at openjdk.org> wrote:

> Hi all,
> 
> Please review this change that updates the isReady condition for the notifier. Instead of having this as a configurable
> option, just use the well-known values.
> Best regards,
> Robin

Looks good!

bots/notify/src/main/java/org/openjdk/skara/bots/notify/NotifyBot.java line 69:

> 68:
> 69:     private boolean isReady(PullRequest pr) {
> 70:         var labels = new HashSet<>(pr.labels());

Perhaps rename `isOfInterest`?

-------------

Marked as reviewed by ehelin (Reviewer).

PR: https://git.openjdk.java.net/skara/pull/660


More information about the skara-dev mailing list