RFR: 383: More fuzzy matching of bug ids in PR titles

Jorn Vernee jvernee at openjdk.java.net
Thu May 14 14:05:50 UTC 2020

On Wed, 13 May 2020 07:40:22 GMT, Robin Westberg <rwestberg at openjdk.org> wrote:

> Hi all,
> Please review this change that allows a more relaxed matching of bug ids in PR titles. Also contains a bit of
> refactoring to make it explicit when the project name could be part of the bug id. There were several places that
> expected the project name to not be present (as they would fetch the issue using the key from a specific project) -
> these now explicitly use the shortId.  Best regards, Robin

LGTM. One minor comment.

vcs/src/main/java/org/openjdk/skara/vcs/openjdk/Issue.java line 89:

> 88:     public String toShortString() {
> 89:         return id + ": " + description;
> 90:     }

Bit confusing here when also looking at the toString method impl. Maybe you should rename the `id` field to `shortId`
now? (to match the method names)


Marked as reviewed by jvernee (Reviewer).

PR: https://git.openjdk.java.net/skara/pull/623

More information about the skara-dev mailing list