RFR [lworld] 8239929: Object.newIdentity() replacement for new Object()

Roger Riggs Roger.Riggs at oracle.com
Fri Feb 28 14:10:45 UTC 2020

Hi John,

I agree shorter is better, but I hope no one gets attached to the name 
of the implementation class.
It should be forgettable, I even wondered if it should be a hidden class.

Also, Object$Identity is too strong a name for this purpose. (and Brian 
has another purpose for that name.)

How about either Object$Id or Object$Instance?


On 2/27/20 10:40 PM, John Rose wrote:
> On Feb 25, 2020, at 11:20 AM, Roger Riggs <Roger.Riggs at oracle.com> wrote:
>> IdentityInstance
> Does anyone else find this name to verbose?
> Folks will see Object$IdentityInstance, like they see AbstractList$SubList.
> I suggest s/IdentityInstance/Identity/, so Object$Identity is the class.

More information about the valhalla-dev mailing list