[lworld] RFR: 8247357: Flattenable field concept needs some cleanup

John Rose john.r.rose at oracle.com
Wed Jun 10 19:36:26 UTC 2020

On Jun 10, 2020, at 12:30 PM, John Rose <john.r.rose at oracle.com> wrote:
> So I suggest:
> s/is_flattenable/is_declared_inline/
> s/is_flattened/is_allocated_inline/
> Maybe that’s overkill?  But I think just “is_inline” is not clear enough.

To be clear:  I’m not suggesting that systematically, just where
the distinction exists between “could be” and “actually is” flattened.
Names like STATIC_INLINE in the CFP are completely unambiguous;
they shouldn’t be STATIC_ALLOCATED_INLINE or the like.

In the CFP, “has_flattenable_fields” could go either way, but I think
“has_declared_inline_fields” would be safer.  It’s not clear whether it
means “my definer has declared inline fields in me”, or “I actually
flattened one or more of my fields”.

More information about the valhalla-dev mailing list