[lworld] RFR: 8260606: Update Valhalla core-libs naming for methods related to primitive classes

Mandy Chung mchung at openjdk.java.net
Wed Feb 3 19:27:55 UTC 2021


On Tue, 2 Feb 2021 20:55:07 GMT, Roger Riggs <rriggs at openjdk.org> wrote:

> Update terminology used to refer to primitive classes (from inline classes).
> Drop the descriptions using "projection" and use "conversion" as needed.
> Updated dependencies on Class.isPrimitiveClass().
> 
> [Updating test names will be a separate task.]

Looks good.   Do you want to add `IdentityObject` in a separate PR?  It's okay with me to add this in this PR.

src/java.base/share/classes/jdk/internal/misc/Unsafe.java line 276:

> 274:     }
> 275: 
> 276:     public Object getReferenceVolatile(Object o, long offset, Class<?> vc) {

`vc` parameter should also be renamed to `pc` to be consistent with other methods.

-------------

Marked as reviewed by mchung (Committer).

PR: https://git.openjdk.java.net/valhalla/pull/318


More information about the valhalla-dev mailing list