Simple is as simple does (JEP draft 8323335)

Eirik Bjørsnøs eirbjo at gmail.com
Wed Feb 21 14:49:05 UTC 2024


On Wed, Feb 21, 2024 at 9:47 AM Stephen Colebourne <scolebourne at joda.org>
wrote:

> ie. I think "System" is a better on-ramp name as it actually leads to
> the "real thing"
>

To pull this string a bit more, perhaps we could even tuck this away as a
static class IO in System?

import static java.lang.System.IO.*; // Implicit

println("Hello");
System.IO.println("Goodbye"); // Explicit

That would free the java.io.* namespace of the burden of having a name for
this thing which seems a bit out of place and awkward outside the context
of implicit classes.

(Disclaimer: I'm casually throwing out a thought here without much thought,
that's what bikeshedding is all about, right! :)

Eirik.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/amber-dev/attachments/20240221/5d3c4e92/attachment.htm>


More information about the amber-dev mailing list