Need reviewer: NONFCS_BUILD_INFO to add to the non-fcs version string

David Katleman david.katleman at oracle.com
Wed Nov 24 19:52:57 UTC 2010


  Hi Kelly,

Logic looks fine, just a nit

Unless $(NONFCS_BUILD_INFO) really needs that leading "-", I'd remove it 
and add a "-" in line 110 and 297 below.   Makes it a bit more readable

         Dave


    hotspot/make/defs.make

>   109   else
>   110     HOTSPOT_BUILD_VERSION=internal$(NONFCS_BUILD_INFO)
>   111   endif


    jdk/make/common/shared/Defs.gmk

> 290   ifndef NONFCS_BUILD_INFO
>   291     BUILD_DATE := $(shell $(DATE) '+%Y_%m_%d_%H_%M')
>   292     CLEAN_USERNAME := $(shell $(ECHO) "$(USER)" | $(TR) -d -c '[:alnum:]')
>   293     USER_RELEASE_SUFFIX := $(shell $(ECHO) "$(CLEAN_USERNAME)_$(BUILD_DATE)" | $(TR) '[:upper:]' '[:lower:]' )
>   294     NONFCS_BUILD_INFO = -$(USER_RELEASE_SUFFIX)
>   295   endif
>   296   export NONFCS_BUILD_INFO
>   297   FULL_VERSION = $(RELEASE)$(NONFCS_BUILD_INFO)-$(BUILD_NUMBER)
>   298 endif




On 11/24/2010 11:36 AM, Kelly O'Hair wrote:
> Dang... just shoot me now. :^(
>
> Try this:
>   http://cr.openjdk.java.net/~ohair/openjdk7/nonfcs-version/webrev/
>
> Sorry about that.
>
> -kto
>
> On Nov 24, 2010, at 11:28 AM, Mark Wielaard wrote:
>
>> On Wed, 2010-11-24 at 11:19 -0800, Kelly O'Hair wrote:
>>> I need a reviewer for this change:
>>>
>>> 6987107: Add NONFCS_BUILD_INFO variable to add to but not modify
>>> MILESTONE in version string
>>> http://javaweb.sfbay.sun.com/~ohair/webrevs/jdk7/nonfcs-version/webrev/
>>
>> Bit hard to review if the host isn't reachable :)
>> Could you just attach the patch to your email,
>> or post it on some publicly reachable machine?
>>
>> Thanks,
>>
>> Mark
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.openjdk.org/pipermail/build-dev/attachments/20101124/18557a03/attachment.htm>


More information about the build-dev mailing list