Need official reviewers: hotspot makefile changes from build-infra
Tim Bell
tim.bell at oracle.com
Tue Oct 16 15:23:32 PDT 2012
Hi Kelly:
> These will be integrated into the hotspot-rt forest at http://hg.openjdk.java.net/hsx/hotspot-rt/hotspot/
>
> 8000990: Improve logging in hotspot repo builds for new build-infra
>
> http://cr.openjdk.java.net/~ohair/jdk8/hotspot.build.infra.logging/webrev/
The webrev looks fine to me, but I don't have the required roles to be
an official reviewer.
I need one additional change in the hotspot
*make/windows/makefiles/defs.make* file, which is a search/replace of
USING_MINGW with USING_MSYS:
% gdiff defs.make defs.make.tim
202c202
< # Check for MinGW
---
> # Check for MinGW/MSYS
204c204
< USING_MINGW=true
---
> USING_MSYS=true
218c218
< else ifeq ($(USING_MINGW), true)
---
> else ifeq ($(USING_MSYS), true)
313c313
< else ifeq ($(USING_MINGW), true)
---
> else ifeq ($(USING_MSYS), true)
> I did not make these changes, so I'd like to create this changeset with an appropriate owner and list of
> reviewers (which I will be one).
> If there are issues to resolve with these changes, it would be best if that appropriate owner made the changes
> in the build-infra forest and I will re-generate the patch.
We use MSYS to build on Windows, but we don't actually need anything
from MinGW. USING_MSYS is a better name for the variable.
The only thing to watch out for is that 'uname -s' on an MSYS system
returns a string like "MINGW32_NT-6.1". Other than that string compare,
we can refer to USING_MSYS throughout the build.
Tim
More information about the build-infra-dev
mailing list