RFR: 8224261: JProgressBar always with border painted around it [v2]
Alexey Ivanov
aivanov at openjdk.org
Mon Nov 20 14:42:31 UTC 2023
On Mon, 20 Nov 2023 05:24:59 GMT, Abhishek Kumar <abhiscxk at openjdk.org> wrote:
>> test/jdk/javax/swing/JProgressBar/TestProgressBarBorder.java line 70:
>>
>>> 68: isImgSame = Util.compareBufferedImages(borderPaintedImg, borderNotPaintedImg);
>>> 69:
>>> 70: if (isImgSame) {
>>
>> Maybe worth renaming `isImgSame` to something that reads slightly smoother like `isImgEqual`, `isEqual`, or `isMatching`. Could just even inser the `Util.compareBufferedImages()` into the if statement for the failure check if you prefer. But I like the variable for better readability.
>
> Updated to `isImgEqual`.
Grammatically, it should be `areImgsEqual` or `areImagesEqual`.
Would `boolean equal = Util.compareBufferedImages` be enough to convey the meaning?
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/16467#discussion_r1399299440
More information about the client-libs-dev
mailing list