RFR: 8328387: Convert java/awt/Frame/FrameStateTest/FrameStateTest.html applet test to main

Harshitha Onkar honkar at openjdk.org
Tue Mar 19 00:13:20 UTC 2024


On Mon, 18 Mar 2024 21:12:19 GMT, Alexander Zvegintsev <azvegint at openjdk.org> wrote:

> The test is converted to main and remains in the problem list, as the problem is still valid on Linux and macos. 
> The test passes on Windows.
> 
> * sleeps on EDT removed, replaced with the Swing timer
> * Unnecessary ltemListener and variables removed.
> * Updated instructions with html for better readability
> * small log improvements
> * log area from PassFailJFrame used

test/jdk/java/awt/Frame/FrameStateTest/FrameStateTest.java line 179:

> 177:             setLayout(new FlowLayout());
> 178:             add(b1 = new Button("resizable"));
> 179:             add(b2 = new Button("resize"));

@azvegint Minor: Should we consider renaming the "Resize" button to "Change Bounds"? Since when a non-resizable frame is created, the Resize option might seem confusing when we are changing the bounds of the frame.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18366#discussion_r1529490262


More information about the client-libs-dev mailing list