RFR: 8328387: Convert java/awt/Frame/FrameStateTest/FrameStateTest.html applet test to main

Alexander Zvegintsev azvegint at openjdk.org
Tue Mar 19 00:23:20 UTC 2024


On Tue, 19 Mar 2024 00:10:17 GMT, Harshitha Onkar <honkar at openjdk.org> wrote:

>> The test is converted to main and remains in the problem list, as the problem is still valid on Linux and macos. 
>> The test passes on Windows.
>> 
>> * sleeps on EDT removed, replaced with the Swing timer
>> * Unnecessary ltemListener and variables removed.
>> * Updated instructions with html for better readability
>> * small log improvements
>> * log area from PassFailJFrame used
>
> test/jdk/java/awt/Frame/FrameStateTest/FrameStateTest.java line 179:
> 
>> 177:             setLayout(new FlowLayout());
>> 178:             add(b1 = new Button("resizable"));
>> 179:             add(b2 = new Button("resize"));
> 
> @azvegint Minor: Should we consider renaming the "Resize" button to "Change Bounds"? Since when a non-resizable frame is created, the Resize option might seem confusing when we are changing the bounds of the frame.

I am not sure about this, the button does exactly what its label says - resize the frame.

A non-resizable frame has always meant that it can't be resized by the user, but can be changed programmatically.

> java.awt.Frame#setResizable
Sets whether this frame is resizable by the user.

So I prefer to leave it as it is.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/18366#discussion_r1529502937


More information about the client-libs-dev mailing list