Kitchen-sink language problems on mac

Christian Plesner Hansen plesner at
Wed Jun 13 08:02:31 PDT 2007

I've been running jtreg in netbeans using the ant script that comes
with ksl.  When I run it the way it says on the website it fails and
says that it can't find any tests to run.

I've tried adding an argument that specifies the javac tests and
disabled sameVM mode.  That makes it runs the tests but it still gives
a bunch of failures, many of them NoClassDefFoundError.

-- Christian

On 6/12/07, Jonathan Gibbons <Jonathan.Gibbons at> wrote:
> Christian,
> Peter brought the issue of the compiled property files to my attention
> last week.
> I've filed Bug 6568290 to track the issue.
> The short term workaround is to take and use a copy of the property compiler
> from OpenJDK: make/tools/CompileProperties/
> or to write your own class that you can use which will read and use the
> .properties files directly.
> As for the jtreg compiler tests, there are two issues that I know of.
> The shell tests do not work in the mode where you put javac.jar on the
> bootclasspath. The workaround for this is to use the -noshell argument
> to jtreg to (temporarily) exclude those tests.  The other issue that came up
> a couple of weeks ago is that there were some problems running the tests
> in sameVM mode (the -s option.)  The workaround is not to use -s.
> I have a fix for that latter problem, and we will be posting a new
> version of
> jttreg soon, I hope.
> -- Jon
> Christian Plesner Hansen wrote:
> > Hi
> > I've been trying to build the kitchen-sink language project on my mac
> > and have run into some trouble.  I thought you might want to know this
> > so you can either fix it or at least warn about it on the project
> > website.
> >
> > On mac the bootclasspath contains the class files for the default
> > installed version of javac.  This means that when you run
> > dist/bin/javac, it doesn't run the javac you just built but the
> > standard one from the installed j2se.  If you specify javac.jar with
> > -Xbootclasspath/p your javac will be run, but will not use its own
> > property files because the compiled property files from the installed
> > javac takes precedence over the property files from your own
> > javac.jar.
> >
> > Also, a bunch of the jtreg compiler tests fail seemingly also because
> > of classpath/bootclasspath problems.
> >
> >
> > -- Christian

More information about the compiler-dev mailing list