RFR: 8025910 : (s) rename substream(long) -> skip and substream(long, long) -> slice

Brian Goetz brian.goetz at oracle.com
Thu Oct 10 22:44:49 UTC 2013


For skip: should rename the parameters away from "startInclusive" to 
something like "toSkip".

For slice: should probably change back to slice(toSkip, maxSize) rather 
than start/end offsets; in this way, slice is skip+limit.

On 10/8/2013 11:38 PM, Mike Duigou wrote:
> Hello all;
>
> Based upon feedback from the JavaOne Hands-On-Lab and other sources the 335 EG has decided to rename the two substream methods in the Streams interfaces to skip and slice.
>
> Webrev:
>
> http://cr.openjdk.java.net/~mduigou/JDK-8025910/0/webrev/
>
> and the specdiff:
>
> http://cr.openjdk.java.net/~mduigou/JDK-8025910/0/specdiff/overview-summary.html
>
> Thanks,
>
> Mike
>



More information about the core-libs-dev mailing list