RFR: 8025910 : (s) rename substream(long) -> skip and substream(long, long) -> slice
John Rose
john.r.rose at oracle.com
Thu Oct 10 23:56:50 UTC 2013
On Oct 10, 2013, at 3:44 PM, Brian Goetz <brian.goetz at oracle.com> wrote:
> maxSize
"maxFoo" suggests an inclusive limit to "foo". "fooLimit" suggests an exclusive limit.
For slice I suggest "sizeLimit" ("limit" with similar meaning to argument in String.split or java.io.Reader.mark).
On Oct 9, 2013, at 5:45 AM, Paul Sandoz <paul.sandoz at oracle.com> wrote:
> Looks ok, but I have a preference to change the parameter name from "startInclusive" to say "n":
+1, noting java.io.Reader.skip.
— John
More information about the core-libs-dev
mailing list