RFR: 8153044: Allow a property to control location of tzdb.dat file

Roger Riggs Roger.Riggs at Oracle.com
Thu Jul 7 15:32:32 UTC 2016


Hi Sean,

I think I would rename the property to "jdk.time.zone.tzdbfile" to 
reinforce it is captive to the zone implementation.

Though the original code builds the path with string concatenation, I 
think it would be better
to use java.nio.Paths.get() to build it.
   i.e. Paths.get(getProperty("java.home"), "lib", "tzdb.dat").

Also, for the property access in the case of a security manager,
use  sun.security.actions.GetPropertyAction.privilegedGetProperty.

Perhaps rename 'pathToRules' to 'pathToTzdb'

Thanks, Roger



On 7/7/2016 10:53 AM, Seán Coffey wrote:
> Looking to add a new implementation specific system property which 
> would allow the user to specify the location of the tzdb.dat file.
>
> https://bugs.openjdk.java.net/browse/JDK-8153044
> http://cr.openjdk.java.net/~coffeys/webrev.8153044/webrev/
>



More information about the core-libs-dev mailing list