RFR 8154737: Rename VarHandle.compareAndExchangeVolatile to VarHandle.compareAndExchange
Paul Sandoz
paul.sandoz at oracle.com
Wed Jun 22 09:34:34 UTC 2016
Hi,
Please review:
http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8154737-vh-cae-volatile-rename/webrev/ <http://cr.openjdk.java.net/~psandoz/jdk9/JDK-8154737-vh-cae-volatile-rename/webrev/>
This patch renames VarHandle.compareAndExchangeVolatile to VarHandle.compareAndExchange so the naming scheme is consistent with compareAndSet, and is also a little shorter.
The patch is based off hs-comp to keep in sync with other recently pushed changes and avoid possible merging issues. Hence why hotspot-compiler-dev is included, although there are no changes to hotspot.
CCC is approved. This issue is granted an FC exception under JEP 193.
I created a follow on issue to rename the internal Unsafe methods.
https://bugs.openjdk.java.net/browse/JDK-8159995 <https://bugs.openjdk.java.net/browse/JDK-8159995>
But we can do that post 9.
Thanks,
Paul.
More information about the core-libs-dev
mailing list