RFR 8214971 : Replace use of string.equals("") with isEmpty()
Stuart Marks
stuart.marks at oracle.com
Fri Dec 7 17:45:58 UTC 2018
On 12/7/18 4:51 AM, Claes Redestad wrote:
> One possible improvement would to wrap coder() == aString.coder() in a
> method isSameCoder(String):
>
> private boolean isSameCoder(String other) {
> return COMPACT_STRINGS ? coder == other.coder : true;
> }
>
> .. one less method call, but still perfectly optimizable, so less taxing during
> startup with no peak performance drawback.
>
>> (Note, this isn't relevant to the current review.)
>
> But interesting nonetheless :-)
Cool. Glad something useful might come out of this line of discussion.
s'marks
More information about the core-libs-dev
mailing list