RFR: Here are some URLClassPath patches
Martin Buchholz
martinrb at google.com
Wed Feb 21 20:30:25 UTC 2018
OK, we have a reworked set of patches.
(In my corner of openjdk we generally use real javadoc on private elements.)
I reverted private doc comment style to the current maddening
inconsistency, except I couldn't restrain myself from fixing
- // ACC used when loading classes and resources */
+ // ACC used when loading classes and resources
I changed ArrayDeque.push to addFirst, as Peter suggested.
8198480: Improve ClassLoaders static init block
http://cr.openjdk.java.net/~martin/webrevs/jdk/ClassLoaders-static/
https://bugs.openjdk.java.net/browse/JDK-8198480
8198481: Coding style cleanups for
src/java.base/share/classes/jdk/internal/loader
http://cr.openjdk.java.net/~martin/webrevs/jdk/loader-style/
https://bugs.openjdk.java.net/browse/JDK-8198481
8198482: The URLClassPath field "urls" should be renamed to "unopenedUrls"
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-rename-urls/
https://bugs.openjdk.java.net/browse/JDK-8198482
8198484: URLClassPath should use an ArrayDeque instead of a Stack
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-ArrayDeque/
https://bugs.openjdk.java.net/browse/JDK-8198484
8198485: Simplify a URLClassPath constructor
http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-simplify-constructor/
https://bugs.openjdk.java.net/browse/JDK-8198485
More information about the core-libs-dev
mailing list