RFR: Here are some URLClassPath patches

Alan Bateman Alan.Bateman at oracle.com
Fri Feb 23 14:28:47 UTC 2018


Just getting to the updated webrev now.

On 21/02/2018 20:30, Martin Buchholz wrote:
> :
>
>
> 8198480: Improve ClassLoaders static init block
> http://cr.openjdk.java.net/~martin/webrevs/jdk/ClassLoaders-static/ 
> <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/ClassLoaders-static/>
> https://bugs.openjdk.java.net/browse/JDK-8198480
The value of jdk.module.main is the name of the "initial module" so 
better to use that instead term of "main module".


>
> 8198481: Coding style cleanups for 
> src/java.base/share/classes/jdk/internal/loader
> http://cr.openjdk.java.net/~martin/webrevs/jdk/loader-style/ 
> <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/loader-style/>
> https://bugs.openjdk.java.net/browse/JDK-8198481
Looks okay.

>
> 8198482: The URLClassPath field "urls" should be renamed to "unopenedUrls"
> http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-rename-urls/ 
> <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/URLClassPath-rename-urls/>
> https://bugs.openjdk.java.net/browse/JDK-8198482
Looks okay.

>
> 8198484: URLClassPath should use an ArrayDeque instead of a Stack
> http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-ArrayDeque/ 
> <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/URLClassPath-ArrayDeque/>
> https://bugs.openjdk.java.net/browse/JDK-8198484
Can copyToArrayDeque use addAll?


>
> 8198485: Simplify a URLClassPath constructor
> http://cr.openjdk.java.net/~martin/webrevs/jdk/URLClassPath-simplify-constructor/ 
> <http://cr.openjdk.java.net/%7Emartin/webrevs/jdk/URLClassPath-simplify-constructor/>
> https://bugs.openjdk.java.net/browse/JDK-8198485
>
Looks okay.


More information about the core-libs-dev mailing list