RFR: 8166026: Refactor java/lang shell tests to java [v2]
Ivan Šipka
isipka at openjdk.java.net
Thu Dec 3 23:23:56 UTC 2020
On Thu, 3 Dec 2020 19:37:11 GMT, Ivan Šipka <isipka at openjdk.org> wrote:
>> Refactor `test/jdk/java/lang/Thread/UncaughtExceptions.sh` as java test.
>
> Ivan Šipka has updated the pull request incrementally with one additional commit since the last revision:
>
> 8166026: Refactor java/lang shell tests to java
> Please rename the class Seppuku to a more generic name for a process that exits as the result of an uncaught exception. Perhaps a simple "UncaughtExit".
How does `UncaughtExitSimulator` sound?
test/jdk/java/lang/Thread/UncaughtExceptionsTest.java line 94:
> 92: final static String EXPECTED_RESULT = "OK";
> 93:
> 94: public static void seppuku() { throw new RuntimeException("Seppuku!"); }
@RogerRiggs I suggest method name instead of `seppuku` to be `throwRuntimeException`?
And to remove the message from the exception constructor.
-------------
PR: https://git.openjdk.java.net/jdk/pull/1578
More information about the core-libs-dev
mailing list