RFR: 8286825: Linker naming cleanup
Jorn Vernee
jvernee at openjdk.java.net
Wed May 18 17:24:44 UTC 2022
This patch is a batch naming cleanup for the foreign linker implementation.
The naming changes are as follows:
- ProgrammableInvoker -> DowncallLinker
- ProgrammableUpcallHandler -> UpcallLinker
- 'native invoker' -> 'downcall stub'
- 'optimzed entry blob' -> 'upcall stub'
- OptimizedEntryBlob -> UpcallStub
- optimized_entry_frame -> upcall_stub_frame
Then renaming of some hotspot files:
- universalNativeInvoker* -> downcallLinker*
- universalUpcallHandler* -> upcallLinker*
- foreign_globals* -> foreignGlobals* (to match existing convention)
Method, field, and other variable names are also adjusted accordingly.
-------------
Commit messages:
- 8275648: Linker naming bikeshed
Changes: https://git.openjdk.java.net/jdk/pull/8777/files
Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=8777&range=00
Issue: https://bugs.openjdk.java.net/browse/JDK-8286825
Stats: 2397 lines in 84 files changed: 1086 ins; 1090 del; 221 mod
Patch: https://git.openjdk.java.net/jdk/pull/8777.diff
Fetch: git fetch https://git.openjdk.java.net/jdk pull/8777/head:pull/8777
PR: https://git.openjdk.java.net/jdk/pull/8777
More information about the core-libs-dev
mailing list