RFR: 8294989: ResourceBundle naming convention issue in JdbcRowSetResourceBundle.java [v8]
Lance Andersen
lancea at openjdk.org
Fri Oct 21 18:13:37 UTC 2022
On Fri, 21 Oct 2022 17:35:22 GMT, Justin Lu <duke at openjdk.org> wrote:
>> Issue: Resource bundle name does not follow proper naming conventions according to [getBundle method](https://docs.oracle.com/en/java/javase/18/docs/api/java.base/java/util/ResourceBundle.html#getBundle(java.lang.String,java.util.Locale,java.lang.Module)) for base name parameter
>>
>> Fix: Modified bundle name to be a fully qualified class and added regression tests.
>
> Justin Lu has updated the pull request incrementally with one additional commit since the last revision:
>
> Pass exception to constuctor directly
Hi Justin,
A few minor change requests.
Thank you for tackling this
test/jdk/javax/sql/testng/test/rowset/ValidateResourceBundleAccess.java line 41:
> 39: public class ValidateResourceBundleAccess{
> 40: // Expected JDBCResourceBundle message, jdbcrowsetimpl.invalstate
> 41: private static final String invalidState = "Invalid state";
Please make the constant names upper case
test/jdk/javax/sql/testng/test/rowset/ValidateResourceBundleAccess.java line 63:
> 61: // Unexpected case where exception is not forced
> 62: throw new RuntimeException(
> 63: String.format("$$$ Error: SQLException was not caught!%n"));
As you are not passing any parameters, this can just be a String omitting the "%n"
Also, it would tweak the String to be "Expected SQLException.... thrown"
test/jdk/javax/sql/testng/test/rowset/ValidateResourceBundleAccess.java line 72:
> 70: // Unexpected case where exception is not forced
> 71: throw new RuntimeException(
> 72: String.format("$$$ Error: SQLException was not caught!%n"));
Same comment about not needing to use String.format.
Also, it would tweak the String to be "Expected SQLException.... thrown"
-------------
Changes requested by lancea (Reviewer).
PR: https://git.openjdk.org/jdk/pull/10612
More information about the core-libs-dev
mailing list