RFR: 8219567: Name of first parameter of RandomAccessFile(String,String) is inconsistent
Jaikiran Pai
jpai at openjdk.org
Sun Aug 20 06:31:37 UTC 2023
On Fri, 18 Aug 2023 23:14:20 GMT, Brian Burkhalter <bpb at openjdk.org> wrote:
> Revise some verbiage about the `RandomAccessFile(String,String)` constructor so that the string name of a file is referred to as _pathname string_ for consistency with `java.io.File`.
src/java.base/share/classes/java/io/RandomAccessFile.java line 213:
> 211: * @throws SecurityException if a security manager exists and its
> 212: * {@code checkRead} method denies read access to the file
> 213: * or the mode is {@code "rw"} and the security manager's
GitHub UI isn't allowing me to add a review comment on line 195, so adding it here. Should line 195 be changed to say:
also called with the pathname of the {@code file} argument to see if write access to the file...
to match what it says a few lines above for the `checkRead` security check?
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/15351#discussion_r1299313238
More information about the core-libs-dev
mailing list