RFR: 8219567: Name of first parameter of RandomAccessFile(String,String) is inconsistent [v2]

Brian Burkhalter bpb at openjdk.org
Mon Aug 21 15:44:57 UTC 2023


On Sun, 20 Aug 2023 06:28:26 GMT, Jaikiran Pai <jpai at openjdk.org> wrote:

>> Brian Burkhalter has updated the pull request incrementally with one additional commit since the last revision:
>> 
>>   8219567: Align checkWrite() verbiage with that of checkRead()
>
> src/java.base/share/classes/java/io/RandomAccessFile.java line 213:
> 
>> 211:      * @throws      SecurityException  if a security manager exists and its
>> 212:      *             {@code checkRead} method denies read access to the file
>> 213:      *             or the mode is {@code "rw"} and the security manager's
> 
> GitHub UI isn't allowing me to add a review comment on line 195, so adding it here. Should line 195 be changed to say:
> 
> 
> also called with the pathname of the {@code file} argument to see if write access to the file...
> 
> to match what it says a few lines above for the `checkRead` security check?

You are correct - thanks. So changed in ef91651b35cd30a7a11ac75ebbdc03a9c29c59e3.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/15351#discussion_r1300295699


More information about the core-libs-dev mailing list