RFR: 8304014: Convert test/jdk/java/util/zip/ZipFile/CorruptedZipFiles.java to testNG [v2]
Eirik Bjorsnos
duke at openjdk.org
Wed Mar 29 12:19:18 UTC 2023
> CorruptedZipFiles could benefit from some spring cleaning and a conversion to testNG:
>
> - The actual tests are moved into their own `@Test` methods, given more meaningful names and a Javadoc comment explaining the constraint being verified
> - The setup code is moved to a `@Before` method, slightly modernized and rewritten to take advantage of `assertEquals`
> - `checkZipExceptionImpl` is updated to take advantage of `expectThrows`
> - A bunch of constants copied over from `ZipFile` can be deleted since JDK-6225935 has long been fixed
Eirik Bjorsnos has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains ten additional commits since the last revision:
- Replace the u8, u16, u32 methods with using a little-endian ByteBuffer. Collapse the checkZipException and checkZipExceptionInGetInputStream into one method by always consuming the InputStream. Add a block comment for the assertZipException method.
- Use block comments instead of javadoc comments
- Merge branch 'master' into corrupted-zip-files-ng
- Merge branch 'master' into corrupted-zip-files-ng
- Give the @BeforeMethod and @AfterMethod more meaningful names
- Improve comments and method names to help future maintainers understand what these tests verify.
- Merge branch 'master' into corrupted-zip-files-ng
- Trim whitespace and fix some spelling
- Convert test CorruptedZipFiles to testNG and delete ZipFile constants copies which are now obsolete.
-------------
Changes:
- all: https://git.openjdk.org/jdk/pull/12563/files
- new: https://git.openjdk.org/jdk/pull/12563/files/f2fd8974..e46fc5b3
Webrevs:
- full: https://webrevs.openjdk.org/?repo=jdk&pr=12563&range=01
- incr: https://webrevs.openjdk.org/?repo=jdk&pr=12563&range=00-01
Stats: 96611 lines in 1305 files changed: 56104 ins; 28357 del; 12150 mod
Patch: https://git.openjdk.org/jdk/pull/12563.diff
Fetch: git fetch https://git.openjdk.org/jdk.git pull/12563/head:pull/12563
PR: https://git.openjdk.org/jdk/pull/12563
More information about the core-libs-dev
mailing list