RFR: 8304014: Convert test/jdk/java/util/zip/ZipFile/CorruptedZipFiles.java to testNG [v2]

Daniel Fuchs dfuchs at openjdk.org
Wed Mar 29 13:25:57 UTC 2023


On Wed, 29 Mar 2023 12:19:18 GMT, Eirik Bjorsnos <duke at openjdk.org> wrote:

>> CorruptedZipFiles could benefit from some spring cleaning and a conversion to testNG:
>> 
>> - The actual tests are moved into their own `@Test` methods, given more meaningful names and a Javadoc comment explaining the constraint being verified
>> - The setup code is moved to a `@Before` method, slightly modernized and rewritten to take advantage of `assertEquals` 
>> - `checkZipExceptionImpl` is updated to take advantage of `expectThrows`
>> - A bunch of constants copied over from `ZipFile` can be deleted since JDK-6225935 has long been fixed
>
> Eirik Bjorsnos has updated the pull request with a new target base due to a merge or a rebase. The incremental webrev excludes the unrelated changes brought in by the merge/rebase. The pull request contains ten additional commits since the last revision:
> 
>  - Replace the u8, u16, u32 methods with using a little-endian ByteBuffer. Collapse the checkZipException and checkZipExceptionInGetInputStream into one method by always consuming the InputStream. Add a block comment for the assertZipException method.
>  - Use block comments instead of javadoc comments
>  - Merge branch 'master' into corrupted-zip-files-ng
>  - Merge branch 'master' into corrupted-zip-files-ng
>  - Give the @BeforeMethod and @AfterMethod more meaningful names
>  - Improve comments and method names to help future maintainers understand what these tests verify.
>  - Merge branch 'master' into corrupted-zip-files-ng
>  - Trim whitespace and fix some spelling
>  - Convert test CorruptedZipFiles to testNG and delete ZipFile constants copies which are now obsolete.

High level comment: these days we usually try to use junit 5 / jupiter instead of TestNG.

-------------

PR Comment: https://git.openjdk.org/jdk/pull/12563#issuecomment-1488606123


More information about the core-libs-dev mailing list