RFR: 8335290: Rename ClassFile::transform to ClassFile::transformClass

Adam Sotona asotona at openjdk.org
Mon Jul 1 07:26:17 UTC 2024


On Fri, 28 Jun 2024 22:01:33 GMT, Chen Liang <liach at openjdk.org> wrote:

> `ClassFile::transform` was initially `ClassModel::transform`, which transforms the receiver class model to a new class byte array. This functionality was in parallel with `ClassBuilder::transform`, which accepts a `ClassModel` and a `ClassTransform` and forwards the results to the receiver builder.
> 
> After the `ClassFile` context object introduction, `ClassModel::transform` becomes `ClassFile::transform`; now, its role is more similar to `ClassBuilder::transformMethod`, `ClassBuilder::transformField`, or `MethodBuilder::transformCode` (transforming subtypes), and it is confusing with `ClassFileBuilder::transform` (which accepts the same model type as the built type). We should rename `ClassFile::transform` to `ClassFile::transformClass` to make this method's role more clear.
> 
> This is separate from #19928 as this has much more user impact.

Looks good to me.
It will require refresh before integration as the number of use cases across JDK is growing instantly.

Thanks!

-------------

Marked as reviewed by asotona (Reviewer).

PR Review: https://git.openjdk.org/jdk/pull/19952#pullrequestreview-2150617276


More information about the core-libs-dev mailing list