RFR: 8327138: Clean up status management in cdsConfig.hpp and CDS.java

Matias Saavedra Silva matsaave at openjdk.org
Wed Mar 6 18:48:47 UTC 2024


On Sat, 2 Mar 2024 01:18:06 GMT, Ioi Lam <iklam at openjdk.org> wrote:

> A few clean ups:
> 
> 1. Rename functions like "`s_loading_full_module_graph()` to `is_using_full_module_graph()`. The meaning of "loading" is not clear: it might be interpreted as to cover only the period where the artifact is being loaded, but not the period after the artifact is completely loaded. However, the function is meant to cover both periods, so "using" is a more precise term.
> 
> 2. The cumbersome sounding `disable_loading_full_module_graph()` is changed to `stop_using_full_module_graph()`, etc.
> 
> 3. The status of `is_using_optimized_module_handling()` is moved from metaspaceShared.hpp to cdsConfig.hpp, to be consolidated with other types of CDS status.
> 
> 4. The status of CDS was communicated to the Java class `jdk.internal.misc.CDS` by ad-hoc native methods. This is now changed to a single method, `CDS.getCDSConfigStatus()` that returns a bit field. That way we don't need to add a new native method for each type of status.
> 
> 5. `CDS.isDumpingClassList()` was a misnomer. It's changed to `CDS.isLoggingLambdaFormInvokers()`.

Looks good, thanks! Just one comment on format below.

src/hotspot/share/cds/cdsConfig.hpp line 72:

> 70:   static void  enable_dumping_dynamic_archive()              { CDS_ONLY(_is_dumping_dynamic_archive = true); }
> 71:   static void disable_dumping_dynamic_archive()              { CDS_ONLY(_is_dumping_dynamic_archive = false); }
> 72:   static bool      is_using_archive()                        NOT_CDS_RETURN_(false);

Could you fix the alignment of the method names here?

-------------

Marked as reviewed by matsaave (Committer).

PR Review: https://git.openjdk.org/jdk/pull/18095#pullrequestreview-1920532000
PR Review Comment: https://git.openjdk.org/jdk/pull/18095#discussion_r1514980583


More information about the core-libs-dev mailing list