RFR: 8353888: Implement JEP 510: Key Derivation Function API [v5]
Sean Mullan
mullan at openjdk.org
Fri May 2 18:39:47 UTC 2025
On Fri, 2 May 2025 18:29:14 GMT, Weijun Wang <weijun at openjdk.org> wrote:
>> src/java.base/share/classes/javax/crypto/KDF.java line 491:
>>
>>> 489: + "using the supplied derivation "
>>> 490: + "inputs, using the " + source + " "
>>> 491: + theOne.provider().getName()
>>
>> Suggest rewording as: "inputs with the " + source + " " + theOne.provider().getName() + " provider."
>
> The exception message following uses `"The " + source + " provider " + theOne.provider.getName()`. Shall I also switch to `"The " + source + " " + theOne.provider.getName() + " provider"`?
Yes, good to make it consistent. I think it reads slightly better if the name of the provider comes before "provider".
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/24520#discussion_r2072005947
More information about the core-libs-dev
mailing list