[crac] RFR: 8349365: [CRaC] Handle javaagent adding jars to boostrap/system classpath
Radim Vansa
rvansa at openjdk.org
Thu Feb 6 09:52:46 UTC 2025
On Wed, 5 Feb 2025 13:41:27 GMT, Timofei Pushkin <tpushkin at openjdk.org> wrote:
>> File descriptors owned by `ClassPathEntry` in `ClassLoader` are ignored during checkpoint.
>
> src/hotspot/share/classfile/classLoader.cpp line 823:
>
>> 821:
>> 822: GrowableArray<int> ClassLoader::get_classpath_entry_fds() {
>> 823: log_info(crac)("Listing classpath FDS");
>
> I believe this should be debug, or even trace, or maybe you just forgot to remove this line. If it remains, "FDs" instead of "FDS" would be better.
Oops, forgotten debugging message... I'll remove that.
> src/hotspot/share/classfile/classLoader.hpp line 417:
>
>> 415:
>> 416: // returns list of file descriptors used for both boot and app classpath entries
>> 417: static GrowableArray<int> get_classpath_entry_fds();
>
> I am not sure about the name, I assume it's not `get_classpath_append_entry_fds()` because it also includes `_app_classpath_entries` but when CDS is not included neither are the app entries... And as I understand you are not sure we need these app entries for the issue at all (I am also not sure, would need to get a deeper understanding of where do all other checked FDs come from).
That's correct; I wanted to report all FDs 'owned' by `ClassLoader` so that we don't add another method or rename it when we bump into another use-case that's broken.
-------------
PR Review Comment: https://git.openjdk.org/crac/pull/201#discussion_r1944422376
PR Review Comment: https://git.openjdk.org/crac/pull/201#discussion_r1944421653
More information about the crac-dev
mailing list