[RFC][Icedtea-Web]: Enforce cache size limit.

Andrew Su asu at redhat.com
Tue Apr 19 09:10:30 PDT 2011



----- Original Message -----
> From: "Denis Lila" <dlila at redhat.com>
> To: "Andrew Su" <asu at redhat.com>
> Cc: "IcedTea" <distro-pkg-dev at openjdk.java.net>
> Sent: Tuesday, April 19, 2011 11:28:18 AM
> Subject: Re: [RFC][Icedtea-Web]: Enforce cache size limit.
> Can you replace this:
> 
> > - String rStr = value.substring(cacheDir.length());
> > + String rStr = file.getPath().substring(cacheDir.length());
> >                      rStr = cacheDir + rStr.substring(0,
> >                      rStr.indexOf(File.separatorChar, 1));
> > + long len = file.length();
> 
> with
> 
> String rStr = cacheDir + File.separatorChar +
> CacheLRUWrapper.getIdForCacheFile(value);
> 
> We already have the id extraction logic encapsulated in a function.
> There's no need to re-implement it in here (but this require some
> visibility changes. Maybe move getIdForCacheFile to CacheUtil?).

I think this should be in its own patch for refactoring, not related to handling cache size.

> 
> 
> > + curSize += len;
> >                          keep.add(value.substring(rStr.length()));
> >                          keep.add(rStr); // We can just use the same
> >                          map, since these two things are disjoint
> >                          with each other.
> 
> Can you please introduce a new Set<String>? I understand that
> they're disjoint, but it's still clearer and closer to what we
> want to have two sets: one for use in removeUntracked, and
> one for use in cleanCache.
> That way correctness would be obvious. This way the reader
> has to think about tricky corner cases.

Same as above, should be done in another patch for refactoring.

--snip--

Cheers,
 Andrew



More information about the distro-pkg-dev mailing list