Reviewer needed: fixed syntax of TestRSA regression test to be compatible with JDK6

Andrew Hughes ahughes at redhat.com
Wed May 9 07:53:31 PDT 2012


----- Original Message -----
> Hi,
> 
> I'd like to push patch containing fix for TestRSA regression test to
> IcedTea6.
> The test TestRSA has been backported to IcedTea6 from OpenJDK7 and
> it's original
> source contains new JDK7 syntax on many places:
> 
> catch (Exception1 | Exception2 | Exception3)
> 
> this needs to be fixed to use a set of catch (ExceptionN) blocks.
> 
> ChangeLog entry:
> 
> 2012-05-09  Pavel Tisnovsky  <ptisnovs at redhat.com>
> 
>         * patches/TestRSA-jdk6-syntax.patch:
>         Make the test TestRSA compatible with JDK6 syntax.
> 
> Can anybody please review this (harmless :-) change?
> 

Yes, I was aware of this, but haven't had time to fix it yet.

This is fine, but can we have a better name for the patch please: 
patches/remove_multicatch_in_testrsa.patch

(I don't like all this mixed case in filenames).

> Thank you in advance,
> Pavel T.
> 
> 
> [Text File:hg.diff]
> 

-- 
Andrew :)

Free Java Software Engineer
Red Hat, Inc. (http://www.redhat.com)

PGP Key: 248BDC07 (https://keys.indymedia.org/)
Fingerprint = EC5A 1F5E C0AD 1D15 8F1F  8F91 3B96 A578 248B DC07




More information about the distro-pkg-dev mailing list