Reviewer needed: fixed syntax of TestRSA regression test to be compatible with JDK6

Pavel Tisnovsky ptisnovs at redhat.com
Wed May 9 08:07:39 PDT 2012


Andrew Hughes wrote:
> ----- Original Message -----
>> Hi,
>>
>> I'd like to push patch containing fix for TestRSA regression test to
>> IcedTea6.
>> The test TestRSA has been backported to IcedTea6 from OpenJDK7 and
>> it's original
>> source contains new JDK7 syntax on many places:
>>
>> catch (Exception1 | Exception2 | Exception3)
>>
>> this needs to be fixed to use a set of catch (ExceptionN) blocks.
>>
>> ChangeLog entry:
>>
>> 2012-05-09  Pavel Tisnovsky  <ptisnovs at redhat.com>
>>
>>         * patches/TestRSA-jdk6-syntax.patch:
>>         Make the test TestRSA compatible with JDK6 syntax.
>>
>> Can anybody please review this (harmless :-) change?
>>
> 
> Yes, I was aware of this, but haven't had time to fix it yet.
> 
> This is fine, but can we have a better name for the patch please: 
> patches/remove_multicatch_in_testrsa.patch
> 
> (I don't like all this mixed case in filenames).
np and thanks!
> 
>> Thank you in advance,
>> Pavel T.
>>
>>
>> [Text File:hg.diff]
>>
> 




More information about the distro-pkg-dev mailing list