[rfc][icedtea-web] fixfor portalbank.no

Jiri Vanek jvanek at redhat.com
Fri May 3 07:23:42 PDT 2013


On 05/02/2013 07:07 PM, Omair Majid wrote:
> On 05/02/2013 05:44 AM, Jiri Vanek wrote:
>> >              /* Fully consuming current request helps with connection re-use
>> >               * Seehttp://docs.oracle.com/javase/1.5.0/docs/guide/net/http-keepalive.html  */
>> >-            StreamUtils.consumeAndCloseInputStream(httpConnection.getInputStream());
>> >+            HttpUtils.consumeAndCloseConnectionSilently(httpConnection);
> Just a nit: the CloseConnection in the name
> consumeAndCloseConnectionSilently implies that we are calling
> disconnect() or otherwise closing the HttpURLConnection, while we are
> not doing that explicitly to reuse connections.
>

Ouch. I do not wont to rename it any more :(

>> >-    private URL findBestUrl(Resource resource) {
>> >+     URL findBestUrl(Resource resource) {
> I guess the method is exposed so some unit test can exercise this
> method? How about you make this change when adding that unit test itself?

Exactly. And tests went inisde with this :))
And those are loooong, good tests :)
>
>> >+                     if (responseCode < 200 || responseCode >= 300) {
>> >+                         if (JNLPRuntime.isDebug()) {
>> >+                             System.err.println("For "+resource.toString()+" the server returned " + responseCode + " code for "+requestMethod+" request for " + url.toExternalForm());
> Please uses spaces between symbols consistently.
fixed

>
>> >+                     }else {
> Please fix the spacing here: "} else {"
fixed

>
> Cheers,
> Omair

Tahnk you for watch!


J.




More information about the distro-pkg-dev mailing list