[rfc][icedtea-web] fix for multiple in-sequence opened connection

Andrew Azores aazores at redhat.com
Mon Jan 4 16:35:33 UTC 2016


On 04/01/16 10:55 AM, Jiri Vanek wrote:
> There is the patch for
> and so fix for http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2591
>
> According to reporter, it fixed the issue.
> According to myself, i did not found any regeressions.
>
> Well, the patch is not nicest, and as addition, I have no idea how to
> properly test it in unittest.
>
> And as top of worst, I eould like to backport it to 1.6 soon...
>
> Thoughts?
>
>
> J.
>

Just a few thoughts here. The intent of the patch seems fine but I'm not 
sure at a quick glance if this is the best approach.


> +
> +        @Override
> +        public String toString() {
> +            return URL.toExternalForm() + "; " + result + "; " + (lastModified==null?"null":lastModified.toString()) + "; " + length==null?"null":length.toString() + "; ";
> +        }
> +
> +
> +
> +

Can the extra blank lines at the bottom be removed? And can the toString 
be moved to the end of the class? The formatting just seems strange. The 
toString body is also a little hard to read, it could probably do with 
some internal whitespaces and some linebreaks at the '+'.

> -    private static class CodeWithRedirect {
> +     static class CodeWithRedirect {
>
>          int result = HttpURLConnection.HTTP_OK;
>          URL URL;
> +
> +        Long lastModified;
> +        Long length;
>

"CodeWithRedirect" doesn't seem like a fitting name anymore. It's more 
than that now with the extra fields added. Is adding these fields to 
this class the best way to go? They don't really seem related - they 
feel shoehorned in to me. Maybe there should be some "URLResponse" class 
which has lastModified, length, and codeWithRedirect fields? Just an 
idea, though. I'm not entirely sure that that's the best abstraction.

-- 
Thanks,

Andrew Azores


More information about the distro-pkg-dev mailing list