[rfc][icedtea-web] fix for multiple in-sequence opened connection
Jiri Vanek
jvanek at redhat.com
Tue Jan 5 16:47:20 UTC 2016
On 01/04/2016 05:35 PM, Andrew Azores wrote:
I filled all what yu did not liked - yteh main concenr - bottoms "CodeWithRedirect" issue - I just
renamed the class... I do nto wont ot make more wrappers hierarchy.
However. I could not sleep to dont have those tesetd.
So I created sucessfully tests :)
1) I created test to test rdirect
- thsoe are passing both on patched and unpathced version
2) I created tests which is counting resourcess accesses in our internal server
- and yes, without patch there are always 2 gets. Wit, only 1.
I will push the tests as separate changeset, as I wont to see them failing in my "grab changeset and
test" machine.
THANX!
J.
ps: sorry for formating issues in patch.I need ru run from work and I'm hoping to use your timezone
tobe able to push + test the tests tomorow morning (and so the aptch itself after meeting over
night):)
> On 04/01/16 10:55 AM, Jiri Vanek wrote:
>> There is the patch for
>> and so fix for http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=2591
>>
>> According to reporter, it fixed the issue.
>> According to myself, i did not found any regeressions.
>>
>> Well, the patch is not nicest, and as addition, I have no idea how to
>> properly test it in unittest.
>>
>> And as top of worst, I eould like to backport it to 1.6 soon...
>>
>> Thoughts?
>>
>>
>> J.
>>
>
> Just a few thoughts here. The intent of the patch seems fine but I'm not sure at a quick glance if
> this is the best approach.
>
>
>> +
>> + @Override
>> + public String toString() {
>> + return URL.toExternalForm() + "; " + result + "; " +
>> (lastModified==null?"null":lastModified.toString()) + "; " + length==null?"null":length.toString()
>> + "; ";
>> + }
>> +
>> +
>> +
>> +
>
> Can the extra blank lines at the bottom be removed? And can the toString be moved to the end of the
> class? The formatting just seems strange. The toString body is also a little hard to read, it could
> probably do with some internal whitespaces and some linebreaks at the '+'.
>
>> - private static class CodeWithRedirect {
>> + static class CodeWithRedirect {
>>
>> int result = HttpURLConnection.HTTP_OK;
>> URL URL;
>> +
>> + Long lastModified;
>> + Long length;
>>
>
> "CodeWithRedirect" doesn't seem like a fitting name anymore. It's more than that now with the extra
> fields added. Is adding these fields to this class the best way to go? They don't really seem
> related - they feel shoehorned in to me. Maybe there should be some "URLResponse" class which has
> lastModified, length, and codeWithRedirect fields? Just an idea, though. I'm not entirely sure that
> that's the best abstraction.
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: multipleConnectioinsWithTest.patch
Type: text/x-patch
Size: 60131 bytes
Desc: not available
URL: <http://mail.openjdk.java.net/pipermail/distro-pkg-dev/attachments/20160105/75a4ee6e/multipleConnectioinsWithTest-0001.patch>
More information about the distro-pkg-dev
mailing list