RFR: 8263769: simplify PhaseMacroExpand::extract_call_projections() [v3]
Tobias Hartmann
thartmann at openjdk.java.net
Wed Mar 24 07:15:42 UTC 2021
On Tue, 23 Mar 2021 21:51:53 GMT, Xin Liu <xliu at openjdk.org> wrote:
>> PhaseMacroExpand::extract_call_projections(macro.cpp) is almost identical to
>> CallNode::extract_projections(callnode.cpp). The implementation can be replaced
>> by CallNode::extract_projections.
>
> Xin Liu has updated the pull request incrementally with one additional commit since the last revision:
>
> Rename PhaseMacroExpand::_call_projects to PhaseMacroExpand::_callprojs.
Nice cleanup! I've added some minor style comments.
src/hotspot/share/opto/macro.cpp line 1026:
> 1024: }
> 1025:
> 1026: alloc->extract_projections(&_callprojs, false/*separate_io_proj*/, false/*do_asserts*/);
Please add a whitespace between the argument and the comment: `false /*separate_io_proj*/`. There are multiple occurrences of this.
src/hotspot/share/opto/macro.cpp line 2368:
> 2366: // exception. If it DOES throw an exception we would need the debug
> 2367: // info removed first (since if it throws there is no monitor).
> 2368: assert ( _callprojs.fallthrough_ioproj == NULL && _callprojs.catchall_ioproj == NULL &&
Whitespaces should be removed `assert ( _c` -> `assert(_c`
src/hotspot/share/opto/macro.cpp line 2434:
> 2432:
> 2433: call->extract_projections(&_callprojs, false/*separate_io_proj*/, false/*do_asserts*/);
> 2434: assert ( _callprojs.fallthrough_ioproj == NULL && _callprojs.catchall_ioproj == NULL &&
Whitespaces should be removed assert ( _c -> assert(_c
-------------
Marked as reviewed by thartmann (Reviewer).
PR: https://git.openjdk.java.net/jdk/pull/3105
More information about the hotspot-compiler-dev
mailing list