RFR: 8263769: simplify PhaseMacroExpand::extract_call_projections() [v3]
Xin Liu
xliu at openjdk.java.net
Wed Mar 24 19:48:43 UTC 2021
On Wed, 24 Mar 2021 07:10:49 GMT, Tobias Hartmann <thartmann at openjdk.org> wrote:
>> Xin Liu has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Rename PhaseMacroExpand::_call_projects to PhaseMacroExpand::_callprojs.
>
> src/hotspot/share/opto/macro.cpp line 1026:
>
>> 1024: }
>> 1025:
>> 1026: alloc->extract_projections(&_callprojs, false/*separate_io_proj*/, false/*do_asserts*/);
>
> Please add a whitespace between the argument and the comment: `false /*separate_io_proj*/`. There are multiple occurrences of this.
updated them all.
> src/hotspot/share/opto/macro.cpp line 2368:
>
>> 2366: // exception. If it DOES throw an exception we would need the debug
>> 2367: // info removed first (since if it throws there is no monitor).
>> 2368: assert ( _callprojs.fallthrough_ioproj == NULL && _callprojs.catchall_ioproj == NULL &&
>
> Whitespaces should be removed `assert ( _c` -> `assert(_c`
fixed.
-------------
PR: https://git.openjdk.java.net/jdk/pull/3105
More information about the hotspot-compiler-dev
mailing list