[jdk18] RFR: 8278267: ARM32: several vector test failures for ASHR [v3]
Hao Sun
haosun at openjdk.java.net
Mon Jan 10 02:16:34 UTC 2022
On Tue, 4 Jan 2022 04:25:17 GMT, Dean Long <dlong at openjdk.org> wrote:
>> An assertion should be better, but I didn't find a proper way to add one assertion for `instruct` according to `src/hotspot/share/adlc/Doc/Syntax.doc`.
>>
>> Hence I'd like to put this check to `predicate`, and "bad AD file` assertion would be issued for unexpected cases.
>
> You can put the assert into a helper function. You can look in aarch64.ad for examples.
>
> bool assert_not_var_shift(const Node *n) {
> assert(!n->as_ShiftV()->is_var_shift(), "illegal var shift");
> return true;
> }
>
> [...]
>
> predicate(n->as_Vector()->length() == 8 && assert_not_var_shift(n));
@dean-long I believe your comments are addressed in the latest commit. Could you please help to take a review when you got a chance? Thanks.
-------------
PR: https://git.openjdk.java.net/jdk18/pull/41
More information about the hotspot-compiler-dev
mailing list