RFR: 8301739: AArch64: Add optimized rules for vector compare with immediate for SVE [v3]

Chang Peng duke at openjdk.org
Tue Apr 25 10:13:10 UTC 2023


On Mon, 24 Apr 2023 10:11:08 GMT, Andrew Haley <aph at openjdk.org> wrote:

>> src/hotspot/cpu/aarch64/aarch64_vector_ad.m4 line 3625:
>> 
>>> 3623: instruct vmask$2_immI_sve(pReg dst, vReg src, $1 imm, immI_$2_cond cond, rFlagsReg cr) %{
>>> 3624:   predicate(UseSVE > 0);
>>> 3625:   match(Set dst (VectorMaskCmp (Binary src (ReplicateB imm)) cond));
>> 
>> @theRealAph 
>> The ReplicateXNodes used in match rules are also different in these two marcos.
>> I think we needn't to merge these two marcos since this will introduce some if-else statements which will reduce the readability.
>
>> @theRealAph The ReplicateXNodes used in match rules are also different in these two marcos. I think we needn't to merge these two marcos since this will introduce some if-else statements which will reduce the readability.
> 
> It won't introduce if-else, surely. Not if you make the parts that are different into parameters. Then a reviewer can immediately see which parts of the macros are actually different, rather than needing to do a deep study.;

Sorry for confusion. I will try to rewrite the marcos according to your comments.

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/13200#discussion_r1176301892


More information about the hotspot-compiler-dev mailing list