Integrated: 8320697: RISC-V: Small refactoring for runtime calls

Feilong Jiang fjiang at openjdk.org
Tue Dec 5 07:08:46 UTC 2023


On Sun, 26 Nov 2023 10:52:18 GMT, Feilong Jiang <fjiang at openjdk.org> wrote:

> Hi, please review this refactoring for runtime calls.
> Major changes:
> 1. Unified the runtime calls with the existing MacroAssembler::rt_call. This will remove the duplicate code like `relocate(target.rspec() [&] {...}` to emit uncompressed instructions.
> 2. Removed MacroAssembler::far_branches and made the call sites default to far branches. `branch_range` is 1MB for riscv, and `ReservedCodeCacheSize` will always bigger than `branch_range` in practice. We should remove this unnecessary check and simplify the code logic.
> 3. Renamed MacroAssembler::la_patchable with MacroAssembler::la making it less confusing.
> 4. `far_call` in `rt_call` should use `tmp` instead of the default temporary register `t0`
> 5. Removed some unused codes in `g1BarrierSetAssembler_riscv.cpp`
> 
> 
> Testing:
> - [x] Tier1-3 tested on hifive unmatched board (release)
> - [x] Run non-trivial benchmark workloads (fastdebug)

This pull request has now been integrated.

Changeset: aec38659
Author:    Feilong Jiang <fjiang at openjdk.org>
URL:       https://git.openjdk.org/jdk/commit/aec386596d531345b46be4f674b775df71df1eee
Stats:     253 lines in 15 files changed: 26 ins; 137 del; 90 mod

8320697: RISC-V: Small refactoring for runtime calls

Co-authored-by: Fei Yang <fyang at openjdk.org>
Reviewed-by: fyang, rehn

-------------

PR: https://git.openjdk.org/jdk/pull/16816


More information about the hotspot-compiler-dev mailing list