RFR: 8330844: Add aliases for conditional jumps and additional instruction forms for x86 [v2]
Vladimir Kozlov
kvn at openjdk.org
Mon Apr 22 21:37:29 UTC 2024
On Mon, 22 Apr 2024 20:47:52 GMT, Scott Gibbons <sgibbons at openjdk.org> wrote:
>> Adding infrastructure for JDK-8320448. Aliasing conditional jump instructions; making arrays_equals accessible from stubs; adding some x86 instructions.
>
> Scott Gibbons has updated the pull request incrementally with one additional commit since the last revision:
>
> Undo move of arrays_equals
Can you also remove changes in `arrays_equals` from this PR? It is fine to have them in JDK-8320448 changes.
src/hotspot/cpu/x86/c2_MacroAssembler_x86.cpp line 4503:
> 4501:
> 4502: assert((!expand_ary2) || ((expand_ary2) && (UseAVX == 2)),
> 4503: "Expansion only implemented for AVX2");
BTW, the check in assert could be simplified: `(!expand_ary2 || UseAVX == 2)`
-------------
PR Comment: https://git.openjdk.org/jdk/pull/18893#issuecomment-2070990618
PR Review Comment: https://git.openjdk.org/jdk/pull/18893#discussion_r1575383066
More information about the hotspot-compiler-dev
mailing list