RFR: 8330844: Add aliases for conditional jumps and additional instruction forms for x86 [v2]
Scott Gibbons
sgibbons at openjdk.org
Mon Apr 22 21:45:29 UTC 2024
On Mon, 22 Apr 2024 21:35:05 GMT, Vladimir Kozlov <kvn at openjdk.org> wrote:
>> Scott Gibbons has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Undo move of arrays_equals
>
> src/hotspot/cpu/x86/c2_MacroAssembler_x86.cpp line 4503:
>
>> 4501:
>> 4502: assert((!expand_ary2) || ((expand_ary2) && (UseAVX == 2)),
>> 4503: "Expansion only implemented for AVX2");
>
> BTW, the check in assert could be simplified: `(!expand_ary2 || UseAVX == 2)`
I thought this would make the intent explicitly clear.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/18893#discussion_r1575388290
More information about the hotspot-compiler-dev
mailing list