RFR: 8317349: Randomize order of macro node expansion in C2 [v3]
Daniel Lundén
dlunden at openjdk.org
Tue Feb 6 11:03:54 UTC 2024
On Tue, 6 Feb 2024 10:34:54 GMT, Christian Hagedorn <chagedorn at openjdk.org> wrote:
>> Daniel Lundén has updated the pull request incrementally with one additional commit since the last revision:
>>
>> Update to print level 5 and fix copyright
>
> src/hotspot/share/opto/macro.cpp line 2580:
>
>> 2578: assert(C->macro_count() == (old_macro_count - 1), "expansion must have deleted one node from macro list");
>> 2579: if (C->failing()) return true;
>> 2580: C->print_method(PHASE_AFTER_MACRO_EXPANSION_ARRAYCOPY, 5, n);
>
> Should we rename this to something more generic since we are not only expanding array copy nodes but also locks and subtype checks? Maybe `PHASE_AFTER_MACRO_EXPANSION_STEP`? We could also use the same phase name for the allocations below since we also print the node name with `n` which already provides the required information about what node was expanded.
Sure, that sounds good. Maybe we should just have a single phase `PHASE_AFTER_MACRO_EXPANSION_STEP` to keep things simple? Even for the Opaque and LoopLimit node eliminations (as they are structurally part of the `expand_macro_nodes` function). We can refactor and move that eliminiation outside `expand_macro_nodes` in the RFE.
In summary, we then only have the phases:
flags(BEFORE_MACRO_EXPANSION , "Before Macro Expansion") \
flags(AFTER_MACRO_EXPANSION_STEP, "After Macro Expansion Step") \
flags(AFTER_MACRO_EXPANSION, "After Macro Expansion") \
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17684#discussion_r1479588626
More information about the hotspot-compiler-dev
mailing list