RFR: 8325541: C2 SuperWord: refactor filter / split [v2]
Emanuel Peter
epeter at openjdk.org
Fri Feb 9 15:36:05 UTC 2024
On Fri, 9 Feb 2024 15:18:52 GMT, Emanuel Peter <epeter at openjdk.org> wrote:
>> src/hotspot/share/opto/superword.cpp line 582:
>>
>>> 580:
>>> 581: // Now we only remove packs:
>>> 582: construct_my_pack_map();
>>
>> `construct_my_pack_map()` also asserts that each node is only in one pack after `combine_packs()`. Maybe we should move this code directly to `combine_packs()` as a post-condition.
>>
>> This was already like this before, but it seems like "my" in `_my_pack` in `SWNodeInfo` is redundant and could just be renamed to `_pack`. Then we could also rename this method to something like `map_nodes_to_packs()`. But this exceeds the scope of this PR and could also be done separately if you agree with this suggestion.
>
> I can do that in a future RFE. I hope that the `_packset` and `_my_pack` eventually can become its own class. Then I can rename things everywhere.
[JDK-8325252](https://bugs.openjdk.org/browse/JDK-8325252) C2 SuperWord: refactor the packset
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17785#discussion_r1484463748
More information about the hotspot-compiler-dev
mailing list