RFR: 8325541: C2 SuperWord: refactor filter / split [v2]
Christian Hagedorn
chagedorn at openjdk.org
Mon Feb 12 08:48:59 UTC 2024
On Fri, 9 Feb 2024 15:21:33 GMT, Emanuel Peter <epeter at openjdk.org> wrote:
>> I can do that in a future RFE. I hope that the `_packset` and `_my_pack` eventually can become its own class. Then I can rename things everywhere.
>
> [JDK-8325252](https://bugs.openjdk.org/browse/JDK-8325252) C2 SuperWord: refactor the packset
> I can do that in a future RFE. I hope that the _packset and _my_pack eventually can become its own class. Then I can rename things everywhere.
Sounds good, that's even better. Do you still want to move the assertion code in this PR to `combine_packs()` or also do it separately?
>> Yes. And it does not make sense to print the packset and the filter_name for every round. That is why I have the printing at the end of all rounds below.
>
> During every round, we may remove some packs. And then they are printed with `SW_REJECTIONS`. If I now also print the packset every round, it gets difficult to read.
Makes sense, thanks for the explanation.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17785#discussion_r1485871297
PR Review Comment: https://git.openjdk.org/jdk/pull/17785#discussion_r1485871619
More information about the hotspot-compiler-dev
mailing list