RFR: 8325746: Refactor Loop Unswitching code [v2]
Christian Hagedorn
chagedorn at openjdk.org
Wed Feb 14 11:52:16 UTC 2024
On Wed, 14 Feb 2024 10:59:00 GMT, Emanuel Peter <epeter at openjdk.org> wrote:
>> Suggestion:
>>
>> ResourceMark rm;
>> GrowableArray<CheckCastPPNode*> loop_invariant_check_casts;
>
> We might as well improve the type of the nodes, and the name of the list.
I think the code of this entire method is somewhat confusing. I've just moved it and did not try to refactor this code. I can add the resource mark and do the suggested renaming/retyping.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/17842#discussion_r1489340234
More information about the hotspot-compiler-dev
mailing list